Ubuntu 16.04 installation seveur Lamp Partie 2: Mysql et phpmyadmin

여보세요, 베이어예요 나는 당신과 함께 설치에 대한 자습서를 계속 진행합니다

Ubuntu의 LAMP 서버 1604 마지막으로 설치 방법을 보았습니다 php70과 아파치, 이제 우리는 MySQL 서버를 설치하는 방법을 보게 될 것이다

또한 데이터베이스 관리자 PhpMyadmin을 설치합니다 일부는 그래픽 인터페이스를 사용하기를 선호합니다 행정부와 다른 사람은 명령 줄에서 일하는 것을 선호합니다 설치용 mysql은 쉽다 가장 먼저 우리는 터미널에 가서 확인합니다

업데이트가 있으면 'sudo apt-get update' 우리가 할 것입니다 'sudo apt-get mysql-server 설치' 'y'를 클릭하십시오 설치하다 그때 어쩌면 우리는 php70 라이브러리 MySQL의 일부 기능이있을 수 있습니다 효과가 없다 그러나 우리는 그것을 볼 것입니다 자세한 내용

기본적으로 우리는 어쨌든 볼 것이지만 mysql이 작동 할 것이라고 생각한다 그런 다음 새 창이 나타나고 암호로 'root'mysql을 입력하십시오 아주 좋아 우리는 'root'암호를 반복한다 승인 아주 좋아

MySQL이 설치되어 있는지 확인합니다 '서비스 mysql 상태' 완벽하게 작동합니다 좋아, 우리는 MySQL을 설치했습니다, 지금 설치됩니다 phpMyadmin, 간단 해: 'sudo apt-get install phpmyadmin' 'y'를 클릭하십시오 그런 다음 설치에 15 초가 걸릴 수 있습니다 그것은 일어날 것이다

따라서 항상 apache2를 확인하는 것이 중요합니다 그래서 키보드의 스페이스 바를 누른 다음 'Enter' 'Enter'를 클릭하십시오 phpmyadmin에 비밀번호를 제공하십시오 다시 한번 아주 좋아 이제 우리가 갈거야

PhpMyadmin을 보는 방법 '로컬 호스트 / phpmyadmin' 승인! 우리는 큰 문제가있다 그래서 우려가있다 이러한 문제의 상당 부분은 일부 PHP 라이브러리, 우리가 할 일은 중요한 것들을 설치하는 것입니다 그들은 나의 마지막 비디오에 설치되지 않았다 실제로 첫 번째 비디오에서 말했듯이 보통 php7

0이 제공됩니다 기본적으로 우분투 1604 그러나 현실에서는 그렇지 않습니다 그래서 우리는 추가로 설치해야합니다

라이브러리를 php70 그래서 우리는 이것을 함께 할 것입니다 너는 모두의 목록을 볼 수있다 다음 명령을 사용하여 라이브러리 : 'sudo apt-cache search php7- *' 그럼, 우리는 다수의 'cgi', 'cli'등의 패키지 우리는 그들을 설치하려고합니다 다음 첫 번째 이러한 라이브러리가 존재하는지 여부를 확인하는 것이 항상 중요합니다

그래서 우리는 'cgi'를 설치합니다 'sudo apt-get install php70-cgi' 좋아 그런 다음 'cli' 'sudo apt-get install-cli php70' 좋아, 이미 설치되어 있습니다

그런 다음 '공통' 'sudo apt-get install php70-common' 또한 설치되어 있습니다 우리는 '말아 라' 'sudo apt-get install php70-curl' 좋아, 또 뭐야? 우리는 이미 '컬'을 설치했습니다 우리는 또한 'php mysql'을 설치합니다

여기에서 라이브러리 목록을 볼 수 있습니다 설치할 수 있습니다 여기서는 'cgi'이고, 'cli' '공통' 'curl'입니다 'json'도 있는데, 설치해야합니다 그래서 'sudo apt-get install php7

0-json' 좋아, 이미 설치되어 있습니다 거기에 mysql 'sudo apt-get install mysql-php70' 우리는 아파치 서버를 다시 시작한다 'sudo /etc/initd/apache2 restart' 너무 좋아

localhost에 문제가 있습니까? PhpMyadmin, 나는 여전히 같은 문제가 있습니다 누락 된 부분은 무엇입니까? 나는 그것이 좋게 보인다라고 생각한다 그러나 나는이 오류를 해석하지 않는다? 그래서 내가 볼 수없는 또 다른 문제가 있습니까? 나는 다른 것을 확인한다 '수도 apt-get 업데이트' 또한 'libapache2-mod-php70'을 설치했는지 확인해야합니다 'sudo apt-get install libapache2-mod-php70' 그래서 나는 그것이 문제라고 생각한다

라이브러리 'libapache2-mod-php70'이 설치되지 않았습니다 !!! 좋아, 그래서 나는 모른다 마지막 비디오에서 라이브러리를 설치했는지 여부 따라서이 라이브러리 'libapache2-mod-php70'을 설치하는 것이 중요합니다 아주 좋아

그래서 이제는 'mbstring 확장'문제를 해결하는 것만 남았습니다 간단합니다 우리는이 확장을 설치합니다 : 'sudo apt-get install php70-mbstring' 우리는 apache2를 다시 시작하고, 작동하는지 아닌지 알 수 있습니다

그래서 우리는 더 이상 'mbstring'의 문제가 없지만 여전히 다른 것입니다 누락 된 것은 패킷입니다 : 'php-gettext 'sudo apt-get install php-gettext' 'y'를 클릭하십시오 우리는 apache2를 다시 시작합니다 'Sudo /etc/initd/apache2 restart' 페이지를 새로 고침하고 거기에 'phpMyAdmin'이 있습니다

여기에 있습니다 따라서, phpMyAdmin이 설치되었습니다 그래서 우리가 되풀이한다면 Ubuntu 1604에 LAMP 서버를 설치하려면

1- apache2를 설치해야합니다 2 – 예정대로 우분투 1604에 설치되지 않았기 때문에 -php70을 설치하십시오 나의 마지막 확인 날짜 04/27/2016

그때, 3- 라이브러리 'libapache2-mod-php70'설치하기 4-install 'mysql-server' 5 php70의 다른 라이브러리를 'curl', cgi ','json ','common ','mbstring '으로 설치하십시오 6

'php-gettext'패키지를 설치하십시오 후속 조치에 감사드립니다 평소처럼 질문이있는 경우 물어 보는 것을 주저하지 말고, 콘텐츠가 마음에 든다면 엄지 손가락까지 내 채널을 구독하십시오 고맙습니다 ! 안녕